Input placeholder text not displaying under responsive mode in WordPress search field


I have the following search code. The text Have a Question? Write here and press enter doesn’t appear under responsive mode.

 <div class="input-group" id="suggest">
            <input name="s" id="s" type="text" onKeyUp="suggest(this.value);" onBlur="fill();" class="search-query form-control pull-right" autocomplete="off" placeholder="'.esc_attr__('Have a Question? Write here and press enter','mywiki').'" data-provide="typeahead" data-items="4" data-source="">
            <div class="suggestionsbox" id="suggestions" style="display: none;"> <img src="'.esc_url(get_template_directory_uri().'/img/arrow1.png').'" height="18" width="27" class="upArrow" alt="upArrow" />
              <div class="suggestionlist" id="suggestionslist"></div>
            </div>        
        </div>

I suspect it has something to do with id="s" in the input because if I change it to id="sh" the placeholder text appears.

So my question is why not id="s" and I prefer to use this cos it seems to be a WordPress default. I hate to fix it here and break something else somewhere.

UPDATE: I realized the issue with the original theme that I’m using -> https://fasterthemes.com/demo/mywiki-wordpress-theme/



Source link

Leave a Reply

Your email address will not be published. Required fields are marked *

Previous Article

Spirit Advises Shareholders Not To Act On New JetBlue Offer Yet

Next Article

Judge Grants Protective Order For Mother Of Rajon Rondo’s Children After He Allegedly Pulled A Gun Out & Threatened To Kill Her

Related Posts